EXCEL ZÄHLENWENN

Mit Excel ZÄHLENWENN können Sie die Häufigkeit von Werten in einer Tabelle ermitteln.

Mit der Funktion „zählenwenn“ in Excel können Sie die Häufigkeit doppelter Werte feststellen. In dem folgenden Tipp zeigen wir Ihnen, wie Sie diese Funktion in einer Formel sinnvoll einsetzen.

  • ZÄHLENWENN ermittelt, wie häufig ein abgefragter Wert in einer Tabelle vorkommt.
  • Für mehr als einen Abfragewert bietet Excel die Funktion ZÄHLENWENNS.
  • SUMMEWENN zählt dagegen nicht die Häufigkeit, sondern summiert die Werte, wenn das abgefragte Argument zutrifft.

1. Excel Zählenwenn : Argumente & grundlegende Möglichkeiten

Microsoft Excel bietet eine Vielzahl von Formeln und Funktionen, mit denen sich – bei richtiger Anwendung – viele Probleme und Fragestellungen lösen lassen. Eine dieser praktischen Helfer ist die Zählenwenn-Funktion in Excel.

Zählenwenn ist eine Funktion um festzustellen, wie häufig ein Wert in einem Suchbereich vorkommt. Die Anzahl wird als Ergebnis ausgegeben. Die Formel lautet dabei wie folgt:

=ZÄHLENWENN(Bereich;Suchkriterium)
Syntax von ZÄHLENWENN

Der Suchbereich kann mehrere Zeilen oder Spalten, oder auch einen definierten Bereich umfassen. Das Suchkriterium kann Zahlen, Texte oder Wahrheitswerte haben und dient als Filter. Für doppelte Werte im Suchbereich, welches das Suchkriterium erfüllen, erhöht Excel den Wert in der Zelle mit der Zählenwenn-Formel um 1. Neben Zahlen kann der Suchwert auch ein Datum, Monat oder andere Suchkriterien umfassen.

2. Excel Zählenwenn: Beispiele aus der Praxis

Machen wir die Arbeitsweise an einem Beispiel deutlich.

In einem einfachen Beispiel führen Sie eine Anwesenheitsliste, in welcher Sie auch die Tage im Home-Office vermerkt haben. Für das Finanzamt möchten Sie nun auszählen, wie viel Tage Sie im Home-Office verbracht haben. Für die Anzahl der Tage im Home-Office benötigen Sie nun die folgende Formel:

=ZÄHLENWENN(C3:C380;"Home Office")

Das Ergebnis zählt nun die Anzahl der Tage für das Jahr, in welchen Sie im Home-Office waren.

In dem Excel-Beispiel ermitteln wir mit der ZÄHLENWENN-Funktion die Anzahl der Tage im Home Office.

In dem Excel-Beispiel ermitteln wir mit der ZÄHLENWENN-Funktion die Anzahl der Tage im Home-Office.

2.1. ZÄHLENWENN wenn leer oder wenn nicht leer

In unserem zweiten Beispiel wollen wir ermitteln, wie viele Forderungen noch offen sind, also kein Eintrag im Feld „Bezahlt am“ vorhanden ist. Die Formel hierfür würde ganz simpel lauten:

=ZÄHLENWENN(D2:D11;"")

Die zwei hohen Anführungszeichen ohne Inhalt bedeuten, dass nur nach leeren Zellen gesucht wird.

Excel bietet mit der Funktion =ANZAHLLEEREZELLEN(SUCHBEREICH) aber auch eine eigene Lösung. Für unser Beispiel geben Sie die Zellen D2 bis D12 ein und erhalten dann mit der Formel

=ANZAHLLEEREZELLEN(D2:D11)

das Ergebnis 6, was den Bestellungen ohne ein Bezahldatum entspricht.

zählenwenn ermittelt Anzahl von leeren Zellen

ZÄHLENWENN ermittelt die Anzahl von leeren Zellen.

Die umgekehrte Funktion, also nach Zellen zu suchen, welche nicht leer sind, kann die ZÄHLENWENN-Funktion nicht bieten. Aber auch hierfür hat Excel eine Lösung, welche ANZAHL2 lautet. Diese Funktion zählt alle Zellen, die nicht leer sind. Der Syntax lautet ANZAHL2(Suchbereich). Für unser Beispiel ermitteln wir mit der Formel

=ANZAHL2(D2:D11)

die Anzahl der bezahlten Rechnungen, deren Wert im in der Spalte D (Bezahlt am) also nicht leer ist.

Anzahl nicht leerer Zellen mit der Funktion Anzahl2

Anzahl nicht leerer Zellen mit der Funktion Anzahl2 ermittelt.

2.2. Komplexere Auswertung von Umsatzergebnissen mit ZÄHLENWENN

In Ihrem Unternehmen führen Sie eine Auswertetabelle mit mehreren Standorten und deren Umsatzzahlen für jedes Quartal. Möchten Sie nun schnell feststellen, wie viele Filialen und Quartale mit einem Gewinn abgeschlossen haben, können Sie dies über die ZÄHLENWENN-Funktion realisieren. Die Formel ist wie folgt aufgebaut:

=ZÄHLENWENN(E2:E29;">0")
ZÄHLENWENN für komplexere Aufgaben

ZÄHLENWENN für komplexere Aufgaben.

Mit dieser Formel werden die Inhalte der Zellen „Gewinn“ geprüft und die Anzahl ausgegeben, wie oft der Wert über 0 liegt, also als Gewinn gewertet wird. Statt Zellenangaben können Sie auch mehrere Zellen und Spalten als Bereich bzw. Liste definieren und diesen in der Formel verwenden. Für unser Beispiel haben wir die Spalte E2:E29 als „Gewinn“ benannt und können diesen Bereich dann in der Formel verwenden. =ZÄHLENWENN(Gewinn;">0").

Das Suchkriterium kann eine Zahl, Text oder Bedienung beinhalten. In unserem Beispiel lautet die Bedingung „größer als 0“. Trifft diese zu, zählt die Formel die Anzahl.

3. Weitere Möglichkeiten von ZÄHLENWENN in Excel

Wenn Sie über eine Formel feststellen wollen, wie oft ein Text in einer Tabelle vorkommt, müssen Sie dies in Anführungszeichen setzen, beispielsweise =ZÄHLENWENN(A2:A29;"Dresden"). Im Ergebnis gibt die Formel das Ergebnis „4“ zurück, da Dresden 4x in den Quartalsmeldungen vorkommt.

Statt fester Werte kann die Formel auch mit dem Inhalt anderer Zellen suchen. Für unser Beispiel würden wir gerne die Anzahl von Quartalsergebnissen ermitteln, welche über einem bestimmten Zielwert liegen. Diesen Zielwert geben wir in der Zelle B36 ein und fragen dann mit der Formel

=ZÄHLENWENN(E2:E30;">"&B37)

ab, wie viele Filialen in dem Jahr die Umsatzmarke überschritten haben.

ZÄHLENWENN und Verketten in Excel

ZÄHLENWENN und Verketten in Excel.

Verketten: Damit wir nicht das „>“ mit in den Wert der Zelle B37 eingeben müssen, kann das Kriterium „größer“ mit dem „&“-Zeichen mit der Zelle verkettet werden, sodass nach dem Kriterium „Größer als B37" gesucht wird. Weitere Möglichkeiten zur Verkettung sind beispielsweise <> (ungleich) oder >= (größer oder gleich).

4. Abgrenzung zu SUMMEWENN

Die Funktion SUMMEWENN ist mit ZÄHLENWENN von der Syntax her identisch, macht aber einen großen Unterschied. Statt der Anzahl der Zellen mit dem Kriterium werden die Werte addiert.

Für unser Beispiel würde demnach die Formel =SUMMEWENN (E2:E29;">0") nicht die Anzahl 16, sondern den Wert dieser Quartalsgewinne ausgeben, hier über 14 Millionen.

SUMMEWENN statt ZÄHLENWENN in Excel

SUMMEWENN statt ZÄHLENWENN in Excel.

Die Farbe in der Abbildung kommt durch eine bedinge Formatierung mit Farbe in Excel. Wir haben zur besseren Übersicht die Gewinnwerte mit Farbskalen automatisch und den Wert der Summe über eine bedingte Formatierung mit „größer als“ formatiert.

Bedinge Formatierung in Excel

Eine Bedinge Formatierung in Excel mit Farbe verbessert die Übersichtlichkeit in einer Tabelle.

5. ZÄHLENWENN mit mehreren Argumenten = ZÄHLENWENNS

Die Funktion ZÄHLENWENNS hat den Nachteil, dass Sie nur einen Suchbereich und ein Argument berücksichtigt, was in der Tabelle enthalten ist. Wenn Sie komplexere Suchanfragen mit mehr Daten für eine Zählen-Funktion benötigen, hilft aber auch hier Excel weiter und bietet mit Zählenwenns den passenden Helfer. Der Syntax von ZÄHLENWENNS, welche mehrere Bedingungen erlaubt, lautet wie folgt:

=ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2]…)

Der erste Kriterienbereich und das erste Kriterium dürfen nicht leer bleiben, die weiteren sind dagegen optional. Insgesamt sind bis zu 127 Paare aus Kriterienbereich und Kriterium zulässig. Eine Zählung erfolgt nur, wenn alle Kriterien erfüllt sind.

Für unser Beispiel oben kann mit der ZÄHLEWENNS-Funktion auch eine Abfrage nach der Summe positiver Quartale auf die Filiale bezogen durchgeführt werden. Die Formel mit zwei Kriterien und Bereichen lautet dann:

=ZÄHLENWENNS(A2:A29;"München";E2:E29;">0")
ZÄHLENWENNS

ZÄHLENWENNS erlaubt mehrere Daten zur Abfrage.

29 Bewertungen

1 Stern2 Sterne3 Sterne4 Sterne5 Sterne Ø 4,17
Wie funktioniert die Excel Zählenwenn-Funktion? Wir stellen sie vor und geben Ihnen Beispiele zu Hand
Loading...