XULRunner ist eine Laufzeitumgebung

Der Browser Mozilla Firefox will sich aktualisieren, doch es kommt immer eine Fehlermeldung:
Error: Platform version 1.9.0.7 ist not compatible with
minVersion > = 1.9.0.8
maxVersion < = 1.9.0.8




XULRunner ist eine Abhängigkeit des Firefox. Die Firefox Version wurde z.B. mit XULRunner in Version 1.9.0.7 kompiliert aber XULRunner liegt beim System schon in Version 1.9.0.8 vor (vermutlich durch ein späteres Update), dadurch kann Firefox nicht mehr ausgeführt werden. XULRunner ist eine Laufzeitumgebung für Anwendungen, die auf der "XML User Interface Language" (abgekürzt: XUL) basiert. Auch Mozilla Thunderbird und Songbird verwenden die Laufzeitumgebung XULRunner.

Versionsnummern können abweichen - die hier angegebene Version dient nur als Beispiel.

Lösung:

Im Programmordner von Mozilla Firefox (C:\Programme\Mozilla Firefox) die Datei application.ini öffnen und folgende Zeilen kontrollieren bzw. korrigieren.


Vendor=MozillaName=FirefoxVersion=3.0.8BuildID=2009032609
Copyright=Copyright (c) 1998 - 2009 mozilla.org
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}[Gecko]MinVersion=1.9.0.8MaxVersion=1.9.0.8
[XRE]EnableProfileMigrator=1EnableExtensionManager=1
[Crash Reporter]Enabled=1ServerURL=https://crash-reports.mozilla.comsubmit

 

  • unter 3.0.8 sollte die aktuelle Versionsnummer von Mozilla Firefox stehen.
  • MinVersion=1.9.0.8MaxVersion=1.9.0.8 ändern auf MinVersion=1.9MaxVersion=1.9.0.8


".08" einfach rauslöschen beim Eintrag "MinVersion".
Die Datei application.ini schliessen um zu speichern.

Danach Mozilla Firefox aktualisieren.


Bewertung

Besucherwertung (70 Stimmen)
5 / 6
(Höher ist besser)

Haben Sie Fragen dazu oder Probleme mit dem Tipp, dann melden Sie uns dies über das spezielle Kontaktformular.
Danke sagt das WinTotal-Team.